
Adobe® Photoshop® cs
Automating repetitive tasks in Photoshop can increase productivity as well as save time and money. Almost any com-

mand (or set of commands) in Photoshop can be recorded into an action to be applied repetitively to a single file or 

across multiple file. The most basic action will execute one command such as resizing an image or displaying a dialog 

box. More complex actions can execute multiple commands automating more elaborate tasks. When used with the 

Batch command and/or Droplets, these actions can be applied to multiple files at once, enabling Photoshop to do 

repetitive tasks more quickly than even the best-trained Photoshop user! When repetitive tasks in a more involved 

workflow need to be carried out between applications, then AppleScript, Visual Basic, or JavaScript can be used to 

create scripts which work with Photoshop. In the case of conditional logic (a fancy way of saying “Make a decision”) 

when an action needs to be applied to some files but not others, JavaScript files can be written to fulfill this need.  

One word of caution when first trying to conquer actions - run them on duplicate files, leaving your precious originals 

unaltered. As you become more Action savvy, you can kick off those training wheels, and batch away!

The Actions Palette

If the Actions palette isn’t showing, select Window >  Actions. The Actions palette displays one set of actions called 

Default Actions.atn. Click the disclosure triangle next to the set of actions to reveal its contents. This default set of 

actions contains a variety of different actions used to create special effects and/or increase productivity and can 

be used to see what types of commands can be recorded.  When you have some time, give them a try.  Clicking the 

disclosure triangle again conceals  the contents of the set.  Photoshop has additional pre-made actions which ship 

with the program and can be loaded into the Actions palette. To use these actions, from the Actions palette menu, 

select the set from the bottom of the list (Commands, Frames, Image Effects, Production, Text Effects and/orTextures).  

We’ll talk more about saving and loading actions later.

Creating  single-command actions

Any Action you create needs to be in a “Set”, which looks like a folder. We’re going to start by creating our own Set of 

actions. This allows us to keep them separate from the default set and helps keep them organized. On the Actions 

palette,  select “New Set” from the palette menu. In the New Set dialog box, name the set “Single Commands” (or 

something that will make sense to you), and click OK. On the Actions palette, the new set is automatically targeted 

and any new actions you create will be placed in that set. Note: Both actions and sets of actions can be rearranged 

at any time by simply targeting it (by clicking on it) and dragging it to a new position in the palette.

 To begin, we’ll create a simple action and assign a function key to trigger it.  This will enable a single keystroke to 

automatically carry out a menu command.  By assigning a function key, we can create keyboard shortcuts for com-

mands that don’t have them - for example, image size or flatten Image.  You’re probably saying, “Hey, Photoshop CS 

HAS customizable keyboard shortcuts.” Well, there are still advantages to using Function keys. For example, they 
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increase the total number of keyboard shortcuts available! Before beginning to record the action, open a multi-lay-

ered document (or create a new one). Then, using the Actions palette menu, select “New Action” (or simply click the 

“New Action” icon at the bottom of the palette).

In the New Action dialog box, give the action a name. Use the Set option to define which set Photoshop puts the 

action in. Use the Function Key command to assign a Function key to trigger the action. Note: although it might look 

like there is a relatively small number of function keys to use, they can be used in conjunction with keyboard modi-

fiers,  (Shift and Control on Windows, Shift and Command on the Macintosh) effectively quadrupling the number of 

function keys available. Choose the color coding option to help identify and/or group your actions by color when 

viewing your actions in button mode (more about this later). Finally, click Record to begin recording the action.

While recording, Photoshop will keep track of nearly all of the commands that you choose. (For a list of items that 

can not be recorded, see the end of this tip). Select Layer > Flatten Image. The image is flattened, and the command 

Flatten Image is listed in the Actions palette. Note: when you record an action, Photoshop records what happened 

(as opposed to the exact menu command), so don’t let this confuse you. For example, when adding a new layer, 

Photoshop lists the command as “Make layer” in the Actions palette.

To stop recording, from the Actions Palette, use the fly out menu and select “Stop Recording” (or simply click the stop 

recording icon at the bottom of the palette). To play the action, open a layered file (or revert the one used to create 

the action) and, from the Actions palette, use the fly out menu to select Play (or simply click the play button at the 

bottom of the Actions palette). However, since we assigned a Function-key to the action, we can also use it to  play 

the action. This enables us to have the actions palette closed, saving screen real estate and still run them. Note: if 

you forget which F-key you assigned to an action, use the Actions palette menu to select “Action Options”.  Or,  you 

can select “Button Mode” to view your actions as “pushable” buttons and view any assigned F-keys. You might find 

that working with the actions listed in button mode enables you to select them more quickly. You can also stretch 

the Actions palette in button mode to list multiple columns of buttons along the bottom of your screen. There are, 

however,  a few disadvantages to working in Button Mode:  you can’t target individual steps, nor can you create new 

actions, for example. Select “Button mode” again to return to normal mode.

Now create a second action - this time for resizing an image. Open any file in Photoshop (or create a new one). In 

the Actions palette, select the set in which you’d like the action to be placed, and from the palette menu, select New 

Action. Name the action, assign an F-Key and a color (if desired), and click “Record.”

Select Image > Image Size, and enter the desired size. Click OK. On the Actions palette, note that the Image Size 

command is recorded. If you click on the disclosure triangle next to the Image Size command, you can see that the 

specific parameters that you recorded are listed. 

To stop recording, from the Actions Palette, use the palette menu to select Stop Recording (or simply click the stop 

recording icon at the bottom of the palette). To play the action, open another file (or revert the one that is open) and, 

use the Actions palette menu to select Play (or simply click the play button at the bottom of the Actions palette). Or, 

use the assigned Function key. The image is resized to the same size as the first document.

If you want Photoshop to display the command’s dialog box instead of automatically applying the same recorded 

values to every image, you can click in the empty well to the left of the command (on the Actions palette) to display 

the dialog box.  Now, playing the action results in the Image size box being displayed so that the values can be cus-

tomized as needed on a document-by-document basis.
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Creating  multi-command actions

To create a more complex action that contains multiple steps is as easy as recording multiple commands. For example, 

to create an action that, colorizes the image, applies a filter, and saves the image as a different format, select New 

Action, click record and select the following commands:

• Image > Image Size

• Image > Adjust > Hue/Saturation (check Colorize and use the hue slider to choose the desired color)

• Filter > Sharpen > Unsharp Mask

• File > Save As and select a different file format

• Select Stop Recording.

Play the action on a different file. If you toggle on the dialog option next to the Hue/Saturation command, you can 

specify a different hue for each color.

Making changes to actions

Individual commands, their attributes, or entire actions and sets can be modified, expanded, deleted, duplicated, and 

reordered so if you make a mistake while recording, don’t worry, you can always go back and edit the action later. 

If you want to remove a step from a command, you can select Delete from the Action palette menu, drag the com-

mand to the trash icon on the bottom of the palette, or temporarily exclude a step by clicking the check mark to the 

left of the command. If  you want to add a step, select start recording from the Action palette menu, or if you already 

have that command recorded in another action you can  option (Mac)/alt (Win) drag the command from one action 

to another. (Not using option (Mac)/alt (Win) will simply move the command from one action to another).  If you 

want to record the same command to be performed multiple times, you can select it repeatedly while recording, or 

select Duplicate or Record Again from the Actions palette menu.

Other commands

Some items in Photoshop don’t appear to be recordable.  For example, if you’re recording an action and select View 

> Actual Pixels the image changes on screen (provided you’re not already viewing the image at 100%) but no com-

mand is added to the Action. To add this command, you must select Insert Menu Item from the Action palette menu.  

With the Insert Menu Item dialog box showing, select View > Actual Pixels. You’ll see the path for the command listed 

at the top of the dialog box. Click OK to add the command to the Action. A key difference between recording a step 

and using the Insert Menu Item is that the Insert menu doesn’t allow toggling on and off the dialog box for that 

command. The dialog box option is shown in the Actions palette, but it’s greyed out (In Photoshop CS) and cannot be 

toggled. Therefore if you want to change the values on an image-by-image basis by showing the commands dialog 

box, its better to record the command than insert it. 

Use the Insert Stop command to insert a message, explanation, or reminder. This is especially useful if you’re creating 

and sharing actions with others. Use the Actions palette menu to select “Insert Stop.” In the Record Stop dialog box, 

add a message and choose whether or not to allow the action to continue. If the action requires that something be 

done, (make a selection for example) then do not allow it to continue. If the action is a reminder (such as “Make sure 

the image is RGB before playing the action.”), then check “Allow Continue.” If the action is stopped, click the play 

button at the bottom of the Actions palette to resume playback.

Action and Playback options

In order to change the name of an action, you can either double click the action in the Actions palette, or select Action 
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Options from the Action Palette menu.  You can also change the F-key assigned to the action and color coding in this 

dialog box. If you want to place the action in to another set, drag the name of the action to the new Set. To make a 

copy of the action into another set, hold down the option (Mac)/alt (Win) while dragging the action. 

To control the playback of actions, select Playback options from the Actions palette menu.  Typically I leave mine to 

Accelerated to play the action as fast as possible. However, if you’re trying to troubleshoot your action you might want 

to select some of the other options. Step by step will slow down the action so that the screen redraws the result of 

each step, but that’s typically not slow enough for me. When I’m troubleshooting, I typically enter a number of seconds 

to pause for. This helps me to see what is happening at each step and what I’ve done incorrectly! The option to Pause 

for Audio Annotation pauses the action long enough to play any  audio annotations recorded in the action.

Saving and sharing actions

When you’re finished creating actions, I would suggest that you save them. Photoshop only saves the contents of the 

actions palette when you quit the application. It only took me one experience to learn this. I had spent all evening 

creating a very intricate action with dozens of steps. I finally went to bed without saving the action or quitting Pho-

toshop. Unfortunately, the power decided to go out that night crashing Photoshop without saving the action. Poof, 

all that hard work was gone. Before trying to save an action, you have to know that individual actions cant be saved, 

you must save a Set (although a Set can include only a single action). In fact, only when you have a set targeted in 

the Actions palette will you be able to select Save Actions from the palette menu.  If you’re saving actions that are 

going to be used cross-platform, be sure to include the .atn extension.

 If you’re sharing actions with friends and colleagues, you can use the Actions palette menu to select Load Actions. 

Navigate to the Actions file (.atn) and select Load. The set will now appear in the Actions palette. If you store sets of 

action in  the  Photoshop folder  > Presets > Photoshop Actions folder, then they will automatically appear at the 

bottom of the Actions palette menu so that you can simply select them from the list to load them.  You can also 

choose to Clear All Actions, Reset Actions (to their default) or Replace actions from the Actions palette menu.

Batch Processing

With the introduction of Photoshop CS, you now have additional choices as to how you decide to batch process 

actions. You can either select the images that you want to batch from the File Browser and choose Automate > Batch, 

or you can select File > Automate > Batch.  The advantage of using the File Browser is the additional control you 

have over selecting you images. For example, you can use the search command to find specific images and have the 

File Browser display them in a search results folder. Then you can reorder them into your own custom sort order if 

desired. You can then select all (or even further refine your selection) and batch process those images. This has saved 

me a great deal of time just by allowing me to batch process files that are in many different folders without having 

to make copies or rearrange my folder structure. 

Whichever way that you select to proceed, the batch dialog box will be the same. In the Play area, select the Set and 

the Action desired. In the Source area, select the source files that you want to run the action on:

• Select Folder to select the correct folder of images to process. If you select this option, use the Choose button 

to navigate to the desired folder. 

• Select Import to import PDF Images

• Select Opened Files to use currently opened files

• Select File Browser to use the currently selected images in the File Browser or, if no files are selected in the File 

Browser, then the action is run on all of the files. 
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•Select “Override Action ‘Open’ Commands” if you want any Open commands (recorded in the action) to be 

ignored.  Note that if you include the open command as part of an action, Photoshop will open the SAME file 

each time the action is performed. Unless you want the same file modified over and over, deselect this option.

Activating this option is handy if you need to open a specific file, such as a backdrop, which does need to be 

used for more than one file. 

• Select “Include All Subfolders” to process files in folders within the master folder you’re selecting. 

• Select “Suppress File Open Options Dialogs” if you want Photoshop to bypass The Camera Raw dialog box, 

opening Raw files with their default settings or with any setting applied to them.

• Select “Suppress Color Profile Warnings” to turn off display of color policy messages. 

Choose a destination for the processed files from the Destination menu.

• “None” leaves files open without saving changes (unless the action includes a Save command).  This gives you 

an opportunity to see the results of the action before saving the file.

• “Save and Close” saves the files in their current location, OVERWRITING the original files.

• “Folder” saves the processed files to a folder in another location. If you select Folder, click Choose to specify 

the destination folder. 

Select  “Override Action Save In Commands” to ignore any save commands recorded in the action. Deselect the 

option if the action contains Save As commands for specific files that are required by the action. For example, if you 

have an image that is the front cover of your newsletter, you could choose to resize, color balance, and sharpen the 

image, and then save it as “frontcover.psd” for importing into InDesign. This allows you to have an intermediary file 

as the result and leave the original image intact.

If you chose “Folder” as the destination, specify a file-naming convention or add your own in the text entry fields. In 

Photoshop CS, you can begin a sequentially numbered list at any number desired by entering that number in the 

“Starting Serial#” box. Check the options for file compatibility (for Windows, Mac OS and Unix) when moving files 

cross-platform or utilizing on the web. 

Finally, select an option for error processing from the Errors pop-up menu: “Stop for Errors” will suspend the process 

until you confirm the error message. “Log Errors to File” will record each error in a file without stopping the process. 

If errors are logged to a file, a message will appear after processing to notify you that errors had occured. 

Creating Droplets

You can think of Droplets as self running applications that perform actions that are associated with it on files dragged 

onto the droplet. To create a Droplet select File > Automate > Create Droplet. Click the Choose button to select where 

to save the droplet. For an explanation of the other option in the Create Droplet dialog box, refer to the section on 

Actions above. To use a Droplet, simply drag one or more files (or a folder of files) onto the Droplet. Droplets continue 

to reference the needed Actions inside Photoshop so don’t discard your Actions after creating droplets for them! 

However, you can make changes to the Action and the Droplet will still work and will incorporate any changes made 

to the Action. Note: Droplets automatically launch Photoshop if it’s not running.

10 useful tips when creating actions and droplets:

1. To play a single step double click on it in the Actions Palette

2. You can save  the steps in an an Actions as a text file by pressing Ctrl+Alt (Windows) or Command+Option 

(Mac) while selecting Save Actions from the Actions palette menu. This is handy for reviewing or printing the 

contents of an Action. However, you can’t reload the text file back into Photoshop.  Note that ALL of the Actions 
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in all sets are printed out, so you may want to limit the number of actions you have loaded to eliminate a lot of 

deleting of unnecessary information. 

3. If you constantly change the default setting for certain dialog boxes (like the default setting for the drop shadow 

in the layer styles dialog box), use actions to modify dialog boxes to open with the defaults that you like.

4. The Batch command itself can be recorded as part of an action to perform multiple batches in sequence. To 

batch process multiple folders without reorganizing them on the hard drive, create aliases within a folder to the 

other folders you want to process, and select the Include All Subfolders option (or use a droplet).

5. When moving a droplet created in Windows to Mac OS, drag the droplet onto the Photoshop icon. Photoshop 

will launch and update the droplet for use in Mac OS. On the Macintosh, add the extension .atn for actions and 

.exe for droplets for cross platform compatibility

6. Record an action within another by playing the action while recording

7. Save out important actions to a secondary folder in case you reinstall Photoshop

8. You can speed up actions by changing the History Palette Options to NOT make an initial snapshot. Also, in 

Preferences > Memory and Image Cache, set the number to “1” for addded speed.

9. To create an action that will work on all files regardless of size, it is necessary to record some commands with 

the rulers set to percentage.

10. There are two “conditional “ commands in Photoshop: Use File > Automate > Fit Image to resize images to fit 

within a specific height OR width (using pixel dimensions) or, to selectively change the color modes of images 

(depending on the mode of the image), select File > Automate > Conditional Mode Change .

Managing Layers when Creating Actions

When selecting a layer in an action, the action records the name of the layer. If the name of the layers change from 

one file to another, it becomes necessary to use the keyboard shortcuts to navigate the Layers palette. Here is a list 

of keyboard shortcuts that you might find handy when recording changes made to specific layers. In the Layers 

palette to: 

Choose the layer above   Option (Mac)/Alt (Win) + [ 

Choose the layer below   Option (Mac)/Alt (Win) + ]

Choose the top layer   Option (Mac)/Alt (Win) + Shift + ]

Choose the bottom layer  Option (Mac)/Alt (Win) + Shift + [

You can also arrange layers by targeting the layer and using the following shortcuts

To move up one layer    Cmd(Mac)/Ctrl (Win) +[

To move down one layer  Cmd(Mac)/Ctrl (Win +]

To move to the top   Cmd(Mac)/Ctrl (Win) +Shift +]

To move to the bottom   Cmd(Mac)/Ctrl (Win) +Shift +[

Three pitfalls to beware of:

1. Size-specific features such as type size, feather, and unsharp mask generally won’t give the effect intended if 

you’re working with files of a different size than that used to record the action. For example, a 3-pixel Gaussian 

blur won’t create the same effect on a 72-ppi file as on a 144-ppi file. 

2. Some of the painting tools, tool options, View options, preferences and window commands cannot be recorded. 

However, many commands that cannot be recorded can be inserted into an action using the Insert Menu Item 

command.

3. There is no way to access the file name while running an action, but you can if you perform a script.
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Scripting in Photoshop:

Photoshop CS automatically installs support for scripting so you can write and run scripts. Scripts can be written 

in AppleScript or JavaScript on the Macintosh. On windows you can use JavaScript, Visual Basic or any other OLE 

Automation. Scropts can range from simple manipulation of a single selected object to complex control of multiple 

documents. They can run commands and even execute actions. 

Photoshop CS installs scripts (found under File > Scripts) that enable you to export layers to individual documents. 

One script allows for exporting multiple layers into individual files making integration with non-Adobe applications 

much easier. In addition, you can export Layer Comps to Files, Layer Comps to PDF, and Layer Comps to Web Photo 

Gallery. These three scripts are great when you want to try out several versions of a design using Layer Comps, and 

then share them with clients. It’s particularly cool that you can do several designs in one document, and then make 

a Web Photo Gallery that features client review tool so that you can conduct a Web-based review very quickly. 

In the Photoshop application folder is a guide to scripting with information on JavaScript, AppleScript, VisualBasic 

as well as sample scripts if you’re interested in making your own. In order to load the additional scripts, simply copy  

them into the Photoshop CS > Presets > Scripts folder. 

Data-driven graphics in ImageReady CS

Data-driven graphics make it possible to produce multiple versions of an image quickly and accurately. Let’s say, for 

example, that you need to produce 500 different Web banners or 200 different business cards based on the same 

template. In the past, you had to manually populate the template with data (images, text, and so on). With data-driven 

graphics, you can use a script referencing a database to generate the Web banners for you. In ImageReady CS you 

can automate this process with the Variables feature. Basically, you design a template in Photoshop or ImageReady, 

putting all of the elements that will change (the variable elements) on separate layers,  and then select layers in the 

template and assign them as variables (in ImageReady). You can then quickly generate an unlimited number of unique 

variations based on the original template by using scripts to replace the variable elements. ImageReady allows you 

to assign three different types of variables:

• Visibility variables let you show or hide the content of a layer.

• Pixel Replacement variables let you replace the pixels in the layer with pixels from another image file.

• Text Replacement variables let you replace a string of text in a type layer.

To define a variable in ImageReady, target the layer and select Image > Variables  Define. In the Variables dialog box, 

choose the desired Variable type and enter names for the variables. Note: Variable names must begin with a letter, 

underscore, or colon and cannot contain spaces or special characters (except for periods, hyphens, underscores, 

and colons). For Pixel Replacement variables, click Pixel Replacement Options, and choose a method for scaling 

the replacement image. To define variables for an additional layer, choose a layer from the Layer pop-up menu and 

repeat the steps above.

Using data sets

A data set is a collection of variables and associated data. You can switch between data sets to upload different data 

into your template. You can create a new set or edit the default data set. To create a new set, select Image Variables 

> Data Set. Then, import the data that you need from an Excel spreadsheet, Filemaker Database or any other source 

data that’s been exported as a comma- or tab-delimited data set.   Or you can simply enter the variable data and click 

the Save Data Set button (to the right of the Data set name) to save the new information. Note: You must define at 

least one variable before you can edit the default data set. To change a data set, simply select the data set you want 
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to modify (from the drop down menu in the Variables dialog box), edit the data and click the Save Data Set button. 

To delete a data set, select the data set you want to delete, and click the Trash button.

Previewing  and Exporting data-driven graphics

The Preview Document mode lets you preview how a template will look when it is rendered using different sets of 

data. To enable (or disable) Preview Document mode either select Image > Preview Document or click the Preview 

Document button in the tool box. Then, in the options bar, choose a data set from the Data Set pop-up menu, click 

the Previous or Next Data Set button. The data being displayued will change in the document window. 

To export Data Driven Graphics, select File > Export > Data Sets as Files. You can output individual images as PSD files, 

optimized images or SWF (Flash) files allowing you to create an unlimited series of graphics for any use, dynamically 

generated, with no programming knowledge required. 


